nsvir nsvir - 3 months ago 15
Android Question

Gradle version 1.8 is required. Current version is 1.6

There is a new Android Studio update: https://sites.google.com/a/android.com/tools/recent/androidstudio030released

The link says:


The improved performance is made possible by changes in Gradle 1.8 and
Android Gradle plugin version 0.6.+


So I changed my dependencies like this:

buildscript {
repositories {
mavenCentral()
}
dependencies {
classpath 'com.android.tools.build:gradle:0.6.+'
}


But I don't know where I can change the Gradle 1.6 to 1.8 ...

And when I compile the app I've got this error:


Gradle: A problem occurred evaluating project.

Gradle version 1.8 is required. Current version is 1.6


Where can I change the version ?

Thanks in advance :)

Answer

I am not sure if this will help you but here is what fixed it for me:

Open up this file in your project:

<Project>/gradle/wrapper/gradle-wrapper.properties

Edit the distributionUrl line and set it too:

distributionUrl=https\://services.gradle.org/distributions/gradle-1.8-all.zip

Rebuild your project.

Update: You might want to use gradle-2.8-all.zip now.

Comments