Tom Tom - 16 days ago 12
Vb.net Question

ClickOnce: unable to install or run the application, requires Microsoft.Vbe.Interop 14.0 to be installed

Just got this message today on user machines when pushing out an update to a ClickOnce VB.NET application.

No new references have been added, just some bug fixes.

Completely lost as to why this is now happening, any one have any ideas? Thanks and full message below.

System Update Required

Unable to install or run the application. The application requires
that assembly Microsoft.Vbe.Interop Version 14.0.0.0 be installed
in the Global Assembly Cache (GAC) first.


Note that this is only happening in XP machines, not Win 7.

Tom Tom
Answer

The problem turns out to be that between the last update and now I installed Office 2010 on my computer and some users are still on 2007. Will solve this by making 2010 a prerequisite since I don't know how to get Interop 12.0.0.0 back on my machine and distributable.

Comments