StatistPiggyTerror StatistPiggyTerror - 2 months ago 5x
Python Question

Why is my Python3 pip package not working eventhough it shows on PyPi?

Here is a little library that I'm trying to make available on PyPi for others to use.

I use this command to upload the package:

$ python sdist bdist_wheel upload

I also tried this:

$ python sdist bdist_egg upload

Both seem to run fine without errors, and it's even listed on PyPi

But for some reason when I try to pip install on Ubuntu, it gives me an error.

# pip3 install libbitcoin
Collecting libbitcoin
Could not find a version that satisfies the requirement libbitcoin (from versions: )
No matching distribution found for libbitcoin

Why is this happening?


luv luv

The name of your package in PyPI is "python-libbitcoin":

pip3 install python-libbitcoin

and here you go:

Downloading/unpacking python-libbitcoin uses an insecure transport scheme (http). Consider using https if has it available
  Downloading python-libbitcoin-1.2.2.tar.gz
  Running (path:/home/lukas/x/build/python-libbitcoin/ egg_info for package python-libbitcoin