drdrdrdr drdrdrdr - 1 month ago 75
Swift Question

Error: Core Data Code generation is not supported for Swift 2.3

I'm getting the error:

Core Data Code generation is not supported for Swift 2.3


since I moved to Swift 2.3 but I cannot find any documentation or previous questions about this issue. Is CoreData not available in Swift 2.3?

enter image description here

mic mic
Answer

Code generation for Core Data is not available for Swift 2.3 as the error states (as of Xcode 8 Beta 2).

Just create your entity classes and your @NSManaged attributes yourself.

In XCode Model Editor you'll find an option in the Data Model Inspector to disable automatic code generation (Class -> CodeGen -> Manual/None).