StackOverflower StackOverflower - 13 days ago 6
ASP.NET (C#) Question

Why I'm getting this incompatibilities issues migrating from .net core rc1 to rc2

I'm trying to make a intermediate step moving from rc1 to rc2 before doing the final migration to v1.0

Right now I'm getting a bunch of incompatibility issues like these


The dependency System.Diagnostics.Process 4.1.0-rc2-24027 does not support framework .NETFramework,Version=v4.5.2.
Severity Code Description Project File Line Suppression State

Error NU1002 The dependency System.IO.FileSystem.Watcher 4.0.0-rc2-24027 does not support framework .NETFramework,Version=v4.5.2.


I'm trying to target .NET Framework 4.5.2 and .net Core

How can I solve this?

Answer

The package System.Diagnostics.Process only supports .Net Standard 1.3, which corresponds to .Net Framework 4.6. So, to use that package, you can't target .Net 4.5.2, but have to target .Net 4.6 or higher.

The same applies to System.IO.FileSystem.Watcher.