Drone Drone - 2 months ago 17
Node.js Question

NPM Installation failed

I have downloaded latest version of nodejs for windows.

When I run command

npm install
it install some package and at last it gives me error


npm WARN optional Skipping failed optional dependency
/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or
architecture:fsevents@1.0.14

npm WARN vue-jwt-auth-example@1.0.0 No repository field.


I am trying to run Vue.js JWT Authentication

Please help, to fix this.

Answer

These are warnings, not errors, so everything still should run fine.

fsevents is an optional dependency, and because it is not supported by your operating system, it is skipped.

The other warning is related to you not having a repository field in your package.json file, so just something to tell you to fix, but not mandatory.

Everything should work fine!