Adam Thompson Adam Thompson - 4 months ago 262
Ruby Question

rack requires Ruby version >= 2.2.2

I'm trying to use

Travis-CI
with a new
Ruby on Rails
project I just started a few days ago. I've tried updating
Travis-CI
to update
rubygems
in
before_install
but still no luck.

Gem::InstallError: rack requires Ruby version >= 2.2.2.

Installing nio4r 1.2.1

An error occurred while installing rack (2.0.1), and Bundler cannot continue.

Make sure that `gem install rack -v '2.0.1'` succeeds before bundling.

Answer

.travis.yml:

rvm: - 2.2.2

(or whatever the latest stable is).