Cheung Brian Cheung Brian - 2 months ago 9x
Node.js Question

cannot npm install karma-ng-html2js-preprocessor

I have found out an annoying problem about the captioned module.

When I install karma-ng-html2js-preprocessor, it always ends in the following error:

>fsevents@0.2.1 install /Library/WebServer/Documents/node_modules/fsevents
>node-gyp rebuild
nam WARN karma@0.10.10 requires a peer of karma-chrome-launcher but none was installed.

What is the cause of the problem? Is there another way to unit-test templateUrl other than using this package?



Okay think I now it.

After you have removed Karma globally, try to install it again with:

npm install karma

Then also run a:

npm install karma --save-dev

Now try to install your ng-html2js-preprocessor by saying:

npm install karma-ng-html2js-preprocessor --save-dev

If this doesn't work please copy the new exception and get back here.