Nikita Nikita - 1 month ago 22
PHP Question

Laravel downgrade 5.2.19 - 5.1.*

I had Laravel Framework version 5.2.19. After changing in composer.json

"laravel/framework": "5.1.*"
and deleting vendor folder I tried
composer install
,but
php artisan --version
it's still 5.2.19. While installing where was no any errors and warnings. And no packages are installed.
If I try to
composer update
,while
php artisan clear-compiled
it will output

Problem 1
- laravel/framework v5.1.9 requires symfony/css-selector 2.7.* ->
satisfiable by symfony/css-selector[2.7.x-dev, v2.7.0, v2.7.0-BETA1,
v2.7.0-BETA2, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14,
v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.3, v2.7.4,
v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9] but these conflict with your
requirements or minimum-stability.


And if i try to update css-selector by adding in require-dev
"symfony/css-selector": "~2.7.*"
. Other versions of css-selector also tried(upper, lower).
How to downgrade properly?

Answer

Ensure your constraints in composer.json match those that shipped with the Laravel 5.1 project skeleton. As per the discussion above, you can remove the symfony/css-selector requirement as that was introduced in Laravel 5.2. Then run composer update to pull in your new dependencies.

Comments