DroidNoob DroidNoob - 9 days ago 5
Ruby Question

RAILS : Bundler could not find compatible versions for gem "actionpack" on installing ActiveAdmin

I added

gem 'activeadmin', github: 'activeadmin'
in my gemfile and did a bundle install. Then it's throwing me the following error.

Bundler could not find compatible versions for gem "actionpack":
In snapshot (Gemfile.lock):
actionpack (= 5.0.0.1)

In Gemfile:
activeadmin (~> 1.0.0.pre4) was resolved to 1.0.0.pre4, which depends on
formtastic (~> 3.1) was resolved to 3.1.4, which depends on
actionpack (>= 3.2.13)

activeadmin (~> 1.0.0.pre4) was resolved to 1.0.0.pre4, which depends on
inherited_resources (~> 1.6) was resolved to 1.6.0, which depends on
actionpack (< 5, >= 3.2)

activeadmin (~> 1.0.0.pre4) was resolved to 1.0.0.pre4, which depends on
inherited_resources (~> 1.6) was resolved to 1.6.0, which depends on
actionpack (< 5, >= 3.2)

activeadmin (~> 1.0.0.pre4) was resolved to 1.0.0.pre4, which depends on
kaminari (~> 0.15) was resolved to 0.17.0, which depends on
actionpack (>= 3.0.0)

activeadmin (~> 1.0.0.pre4) was resolved to 1.0.0.pre4, which depends on
ransack (~> 1.3) was resolved to 1.8.2, which depends on
actionpack (>= 3.0)



Running
bundle update
will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.


I did the bundle update, but still the error is the same. Any help would be appreciated.

EDIT


gem 'activeadmin'
is not compatible with rails 5

Answer

This solution worked for me. For rails 5 you would have to add another gem as follows:

gem 'activeadmin', github: 'activeadmin'
gem 'inherited_resources', github: 'activeadmin/inherited_resources'

To read further, go to this thread.

Comments