Nongthonbam Tonthoi Nongthonbam Tonthoi - 4 months ago 55x
Android Question

Android support library error after updating to 23.3.0

Hi I have been using android support v4 23.1.1 and recently tried to update it to 23.3.0 ( the latest one when this was asked) but I got the following error:

Error:Conflict with dependency ''. Resolved versions for app (23.3.0) and test app (23.1.1) differ. See for details.

So far I have found this

I went to both the links but I could not fix my issue, how do I fix this issue?


I have these in my dependencies

compile ''
compile ''
compile ''
compile ''
compile ''

Previouly all the versions were
and it worked fine the error occurred after updating


Gradle Version 2.10
Gradle Plugin Version 2.0.0
buildToolsVersion "23.0.3"


For those people who are still facing this problem just add this line to your dependencies.

androidTestCompile ''

It solved my problem.