Chester Chester - 1 month ago 16
PHP Question

Web Debug Toolbar doesn't show up symfony 3

I just follow this tutorial. I created a new controller but my web debug toolbar doesn't show up. I accessed it via app_dev.php file, like ,

myurl/web/app_dev/contact/
even if i access my url without the contact the web debug toolbar doesn't show up.

This is my config_dev.yml file:

imports:
- { resource: config.yml }

framework:
router:
resource: "%kernel.root_dir%/config/routing_dev.yml"
strict_requirements: true
profiler: { only_exceptions: false }

web_profiler:
toolbar: true
intercept_redirects: false

monolog:
handlers:
main:
type: stream
path: "%kernel.logs_dir%/%kernel.environment%.log"
level: debug
channels: [!event]
console:
type: console
channels: [!event, !doctrine]
# uncomment to get logging in your browser
# you may have to allow bigger header sizes in your Web server configuration
#firephp:
# type: firephp
# level: info
#chromephp:
# type: chromephp
# level: info

#swiftmailer:
# delivery_address: me@example.com


Do i need to do some extra settings ? I'm totally lost. Thx in advance.

Answer

Double check that you are actually accessing app_dev.php. For example try renaming app_dev.php to a new name 'app_dev_temp.php', then try reloading the page. If you can still access the page you are not where you think you are.

Also check your .htaccess file, if you are using a real server instead of the Symfony built in server, by default the htaccess will direct you to the app.php, not the dev version.