Erik hoeven Erik hoeven -4 years ago 449
Node.js Question

npm install fsevents errors

Hello i'am trying to install fsevents whitch npm. Therefore i use the following versions:


  • Node : 4.2.6

  • NPM : 3.5.2

  • OS : Ubuntu 16.04 LTS

    i 'am executing the statement



Edited

npm install fsevents --no-optional --save react-redux


after executing i get the following errors back in the console

Edited

npm ERR! Linux 4.4.0-45-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "fsevents" "--no-
optional" "--save" "react-redux"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code EBADPLATFORM

npm ERR! notsup Not compatible with your operating system or
architecture: fsevents@1.0.15
npm ERR! notsup Valid OS: darwin
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: linux
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:
npm ERR! /home/erik/git/test/npm-debug.log


Please can you help fix this problem.

Manny thanks

Erik

Answer Source

The comments above tell you what you already know. Perhaps you should've phrased this as a question. :-)

Assuming the question is how to prevent fserrors on a non-Mac system, the solution I found is this:

Remove fserrors from your package.json and remove the folder.

rm -r ./node_modules/fserrors

Then run:

npm rebuild

Problem solved.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download