Ankahathara Ankahathara - 7 months ago 68
Ruby Question

Getting error while installing pods via cocopods on OS X El Capitan

I am running on OSX version 10.11 and Have installed Xcode 7.

I have created a new Xcode project and tried to install Alamofire using cocoa pod.

Following is the log which I am getting to do so. Anyone has any clarifications for this issue ? Thanks

Amiths-iMac:YakadaYakaDev Amith$ pod install

Updating local specs repositories

CocoaPods 0.39.0.rc.1 is available.
To update use:

gem install cocoapods --pre

[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies

dyld: warning, LC_RPATH @executable_path/../../../../../../../SharedFrameworks in /Applications/Xcode.app/Contents/SharedFrameworks/DVTFoundation.framework/Versions/A/../../..//DVTInstrumentsFoundation.framework/Versions/A/DVTInstrumentsFoundation being ignored in restricted program because of @executable_path
dyld: warning, LC_RPATH @executable_path/../lib in /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/../../../../Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/libclang.dylib being ignored in restricted program because of @executable_path
dyld: warning, LC_RPATH @executable_path/../lib in /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/../../../../Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/libLTO.dylib being ignored in restricted program because of @executable_path
dyld: warning, LC_RPATH @executable_path/../Frameworks in /Applications/Xcode.app/Contents/PlugIns/Xcode3Core.ideplugin/Contents/MacOS/Xcode3Core being ignored in restricted program because of @executable_path


[!] Unable to satisfy the following requirements:


  • Alamofire (~> 3.0)
    required by
    Podfile



UPDATE:
When I update my pod file as below

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!
pod 'Alamofire', '~> 2.0'


I am no longer getting the above error !

Answer

Try this

your pod installing

sudo gem install -n /usr/local/bin cocoapods

And Alamofire installing

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod "Alamofire", "~> 3.0.0-beta.3"