der_Fidelis der_Fidelis - 4 days ago 5
Android Question

Android Studio 2.2. Preview 1 error: "Please use JDK 8 or newer"

On trying to run Android Studio 2.2 Preview 1, it gives the following error on gradle build:


Error:Please use JDK 8 or newer.


If I try and do it from the console it says:


FAILURE: Build failed with an exception.


  • Where: Build file 'C:\Coding\Android projects\MaterialScrollBar\app\build.gradle' line: 1

  • What went wrong: A problem occurred evaluating project ':app'.
    com/android/jack/api/ConfigNotSupportedException : Unsupported major.minor version 52.0




I've tried to change the JDK as it suggests from jdk 1.7 to 1.8, but each time I change the JDK location for the project to any other path than the one it currently has it resets back immediately. Even if I change it to other versions of 1.7 it won't change.

I've verified that the environmental variables all point to 1.8 and still no dice. AS 2.1 recognises the JDK as 1.8 for the same project.

Answer

I ran into this issue with a previous version of Android Studio. When I first installed Android Studio I was able to reference JDK 7 in my Program Files directory.

When I upgraded Android Studio and tried to update it to point to JDK 8, which was also in my Program Files directory, I got the same behavior you are seeing. The new path never took and it still used JDK 7.

Turns out Android Studio does not like spaces in the paths to the Android SDK and the JDK. Installing the JDK in a location that does not contain any spaces allowed me to update the location through the Project Structure window.

Comments