rmrps rmrps - 5 months ago 30
CSS Question

NetBeans jqGrid CSS issue

I am using netbeans ide for programming in that recently I am adding jqgrid application for that I am adding following link and script in head of the html

<link rel="stylesheet" type="text/css" href="design/jquery-ui-1.9.2.custom.css"/>
<link rel="stylesheet" type="text/css" href="design/ui.jqgrid.css" />
<script type="text/javascript" src="design/jquery-1.8.3.js"></script>
<script type="text/javascript" src="design/jquery-ui-1.9.2.custom.js"></script>
<script type="text/javascript" src="design/grid.locale-en.js" ></script>
<script type="text/javascript" src="design/jquery.jqGrid.min.js" ></script>


the above links ui.jqgrid.css shows error in netbeans the error is unexpected token dot found the lines are below

* html .jqgrid-overlay {width: expression(this.parentNode.offsetWidth+'px');height: expression(this.parentNode.offsetHeight+'px');}
* .jqgrid-overlay iframe {position:absolute;top:0;left:0;z-index:-1;width: expression(this.parentNode.offsetWidth+'px');height: expression(this.parentNode.offsetHeight+'px');}
* iframe.jqm {position:absolute;top:0;left:0;z-index:-1;width: expression(this.parentNode.offsetWidth+'px');height: expression(this.parentNode.offsetHeight+'px');}


please give me your guidance to resolve this issue

Answer

Probably you use some old version of jqGrid? Look at the ui.jqgrid.css file of jqGrid 4.7.0 or ui.jqgrid.css of jqGrid 4.6.0 and search for expression. You will find the text only in comments. If you use some old version of jqGrid (like 4.5.4 or earlier) you should update it to 4.6.0/4.7.0.