Timestretch Timestretch - 3 months ago 30
Android Question

Android Studio fails to resolve repository

In my project, I'm trying to use the design support library. I have in my Gradle file:

dependencies {
....
compile 'com.android.support:design'
....
}


And when I try to build this, I get the error:

enter image description here

Normally I would just click
Install Repository and sync project
, however, this seems to not work anymore. Clicking this does absolutely nothing, even though clicking
Open File
works fine.

How can I manually install it?

I have the latest Android Support Repository (30.0.0), and Android Support Library (23.2.1) installed.

Answer

I think it is because you've not specified the version.

compile 'com.android.support:design:23.1.1'

change version to what you have downloaded.

Comments