user1995781 user1995781 - 3 months ago 25
iOS Question

ios-deploy fail to install on Mac OS X El Capitan 10.11

I am trying to install ios-deploy on Mac OS X El Capitan 10.11 by running

sudo npm install -g ios-deploy
and it end up with this error message:

sh: line 1: 1106 Abort trap: 6 xcodebuild
npm ERR! Darwin 15.0.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "ios-deploy"
npm ERR! node v4.2.3
npm ERR! npm v2.14.7
npm ERR! code ELIFECYCLE

npm ERR! ios-deploy@1.8.3 preinstall: `./src/check_reqs.js && xcodebuild`
npm ERR! Exit status 134
npm ERR!
npm ERR! Failed at the ios-deploy@1.8.3 preinstall script './src/check_reqs.js && xcodebuild'.
npm ERR! This is most likely a problem with the ios-deploy package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! ./src/check_reqs.js && xcodebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls ios-deploy
npm ERR! There is likely additional logging output above.


Why is it fail? How can I solve it?

Answer

This seems to be an issue since El Capitan. Either try:

npm install -g ios-deploy --unsafe-perm=true

or:

npm install -g ios-deploy --allow-root

This solution is proposed at the relating github from ios-deploy.