David David - 1 month ago 13
Linux Question

Why does aptitude update give me an source.list error?

I'm running a debian (wheezy) Webserver and I'm installing Updates regulary. For that task I use

aptitude update
followed by
aptitude safe-upgrade
. Everytime I go through this procedure I get this output which includes an error message at the bottom:

Hit http://ftp.de.debian.org wheezy Release.gpg
Hit http://ftp.de.debian.org wheezy-updates Release.gpg
Hit http://ftp.de.debian.org wheezy Release
Hit http://ftp.de.debian.org wheezy-updates Release
Hit http://ftp.de.debian.org wheezy/main Sources
Hit http://ftp.de.debian.org wheezy/contrib Sources
Hit http://ftp.de.debian.org wheezy/non-free Sources
Hit http://ftp.de.debian.org wheezy/main amd64 Packages
Hit http://ftp.de.debian.org wheezy/contrib amd64 Packages
Hit http://ftp.de.debian.org wheezy/non-free amd64 Packages
Hit http://ftp.de.debian.org wheezy/contrib Translation-en
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://ftp.de.debian.org wheezy/main Translation-en
Hit http://security.debian.org wheezy/updates Release
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://ftp.de.debian.org wheezy/main Translation-de_DE
Hit http://security.debian.org wheezy/updates/contrib Sources
Hit http://security.debian.org wheezy/updates/non-free Sources
Hit http://ftp.de.debian.org wheezy/main Translation-de
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages
Hit http://ftp.de.debian.org wheezy/non-free Translation-en
Hit http://security.debian.org wheezy/updates/non-free amd64 Packages
Hit http://security.debian.org wheezy/updates/contrib Translation-en
Get: 1 http://ftp.de.debian.org wheezy-updates/main Sources [3,855 B]
Hit http://security.debian.org wheezy/updates/main Translation-en
Hit http://security.debian.org wheezy/updates/non-free Translation-en
Get: 2 http://ftp.de.debian.org wheezy-updates/contrib Sources [14 B]
Fetched 3,869 B in 4s (798 B/s)
W: Failed to fetch http://ftp.de.debian.org/debian/dists/wheezy-updates/Release: Unable to find expected entry 'non/source/Sources' in Release file (Wrong sources.list entry or malformed file)
E: Some index files failed to download. They have been ignored, or old ones used instead.
E: Couldn't rebuild package cache


So I had a look in my source list and I found out that this entry is causing the problem:

(This is only one line of my source list)

deb-src http://ftp.de.debian.org/debian/ wheezy-updates main contrib non free


How can I change the entry to get it working? Is there a security problem here? I appreciate any Tips and Infos on that Topic.

Thank you in advance! :-)

Answer

I found a solution for this. I had to correct the source.list line

deb-src http://ftp.de.debian.org/debian/ wheezy-updates main contrib non free

to

deb-src http://ftp.de.debian.org/debian/ wheezy-updates main contrib non-free

There was a "-" missing between non free. Now I can fire aptitude update without my error. If you still have any tips or information on this topic im happy to read about it, the source.list file is kind of a mysterious for me.

Comments