Jamie Jamie - 2 years ago 3028
Javascript Question

Polyfill for ie

I'm trying to add a

polyfill
to my
vue.js 2.0/Laravel5.3
application because in internet explorer 11 I receive an error:

vuex requires a Promise polyfill in this browser.


So I've followed the docs I'm using ecm 6 so I did:

npm install --save-dev babel-polyfill


And added this at the top in my bootstrap.js:

import "babel-polyfill";


But still the same error in Internet explorer. What should I do or what am I doing wrong here?

Answer Source

If you are using Webpack, find your webpack.base.conf.js file (mine was in the build folder), or the equivalent webpack configuration file, then modify the app entry variable to include babel-polyfill at the start so it looks something like this:

entry: {
    app: ['babel-polyfill', ...]
  },
  .
  .
  .
Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download