Serge Seletskyy Serge Seletskyy - 1 month ago 20
Ruby Question

The heroku command exists in these Ruby versions?

After I updated my Ruby version with rbenv I wasn't able to use the Heroku command-line tool.
I got this error:

> heroku
rbenv: heroku: command not found

The `heroku' command exists in these Ruby versions:
2.0.0-p195


Reinstalling the tool belt from toolbelt.heroku.com didn't help.

Answer

Heroku does not recommend using heroku gem from the recent times. If you have already installed the gem, uninstall the gem first with:

$ gem uninstall heroku

then install the toolbelt from Heroku as specified on Heroku site:

For ubuntu/debian:

$ wget -qO- https://toolbelt.heroku.com/install-ubuntu.sh | sh

For other linux:

$ wget -qO- https://toolbelt.heroku.com/install.sh | sh

For Windows/MacOS see instructions on links.

Comments