Vaibhav Singh Vaibhav Singh - 1 year ago 663
Android Question

How to resolve Gradle plugin requires Studio 3.0 minimum

I am getting

Error:This Gradle plugin requires Studio 3.0 minimum
when importing project

Project repo: https://github.com/chrisbanes/cheesesquare

I had tried mentioned solution provided here and here but nothing worked :(

Answer Source

The repository you're trying to import uses gradle build tools 3.0.0 and gradle 4.0. These aren't supported in Android Studio 2.3, which means that project can only be opened in Android Studio 3.0 preview.

Your options:

1) Download android studio 3.0 preview and use it for the project

2) Check out repository and revert it to just before commit 822b84a1e58126412f708745d8bcee5a525620ae (which is where the conversion to latest version of gradle happened)

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download