Doidgey Doidgey - 10 days ago 6
Python Question

pip - pip install lpthw.web fails

I'm trying to get into Python and part of a tutorial I'm following asks me to download lpthw.web, unfortunately it fails. Python version 2.7.6

I get this when i ran:

pip install lpthw.web
-

Could not find any downloads that satisfy the requirement install
Some externally hosted files were ignored (use --allow-external install to allow).
Cleaning up...
Removing temporary dir c:\users\mat\appdata\local\temp\pip_build_Mat...
No distributions at all found for install


I then ran:
pip install lpthw.web -vvv


Getting page https://pypi.python.org/simple/pip/
URLs to search for versions for pip in c:\python27\lib\site-packages:
* https://pypi.python.org/simple/pip/
Analyzing links from page https://pypi.python.org/simple/pip/
Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.1-py2.py3-none-any.whl#md5=237164a09943d823b954bb9e1
b2a8f67 (from https://pypi.python.org/simple/pip/), version: 1.5.1
Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.2-py2.py3-none-any.whl#md5=445a893564065937c0f31ac2c
c8e2f35 (from https://pypi.python.org/simple/pip/), version: 1.5.2
Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.3-py2.py3-none-any.whl#md5=78126f6352f3d5f29d077be0a
a7f9efa (from https://pypi.python.org/simple/pip/), version: 1.5.3
Found link https://pypi.python.org/packages/py2.py3/p/pip/pip-1.5.4-py2.py3-none-any.whl#md5=f20bc8f31e322375ce06b26d7
3ce7b4f (from https://pypi.python.org/simple/pip/), version: 1.5.4
Found link https://pypi.python.org/packages/source/p/pip/pip-0.2.1.tar.gz#md5=d2af655c1a87e03799442d045c1d6743 (from h
ttps://pypi.python.org/simple/pip/), version: 0.2.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.2.tar.gz#md5=9eda07c8be7105aa774c7eb51c023294 (from htt
ps://pypi.python.org/simple/pip/), version: 0.2
Found link https://pypi.python.org/packages/source/p/pip/pip-0.3.1.tar.gz#md5=78102ddbb040a183dd361b5d432cdf88 (from h
ttps://pypi.python.org/simple/pip/), version: 0.3.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.3.tar.gz#md5=8fccb5b49c6377cbfb1949ccd7be43b3 (from htt
ps://pypi.python.org/simple/pip/), version: 0.3
Found link https://pypi.python.org/packages/source/p/pip/pip-0.4.tar.gz#md5=b45714d04f8fd38fe8e3d4c7600b91a2 (from htt
ps://pypi.python.org/simple/pip/), version: 0.4
Found link https://pypi.python.org/packages/source/p/pip/pip-0.5.1.tar.gz#md5=d4bdaa5f5f5bf8c6263ace75a0882232 (from h
ttps://pypi.python.org/simple/pip/), version: 0.5.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.5.tar.gz#md5=63eed8673e40628534cc0aa9c98e8f3d (from htt
ps://pypi.python.org/simple/pip/), version: 0.5
Found link https://pypi.python.org/packages/source/p/pip/pip-0.6.1.tar.gz#md5=7560e3055c66afb99ac4a7892389a237 (from h
ttps://pypi.python.org/simple/pip/), version: 0.6.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.6.2.tar.gz#md5=9a43e0a2ce8833069f41c347932bdb25 (from h
ttps://pypi.python.org/simple/pip/), version: 0.6.2
Found link https://pypi.python.org/packages/source/p/pip/pip-0.6.3.tar.gz#md5=0602fa9179cfaa98e41565d4a581d98c (from h
ttps://pypi.python.org/simple/pip/), version: 0.6.3
Found link https://pypi.python.org/packages/source/p/pip/pip-0.6.tar.gz#md5=083ff408ca5314cf0561ff79a048cd9a (from htt
ps://pypi.python.org/simple/pip/), version: 0.6
Found link https://pypi.python.org/packages/source/p/pip/pip-0.7.1.tar.gz#md5=420c83ad67bdcb542f772eb64392cce6 (from h
ttps://pypi.python.org/simple/pip/), version: 0.7.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.7.2.tar.gz#md5=cfe73090aaa0d3b0c104179a627859d1 (from h
ttps://pypi.python.org/simple/pip/), version: 0.7.2
Found link https://pypi.python.org/packages/source/p/pip/pip-0.7.tar.gz#md5=8d4b4f7266fe0808569182e6832d74ac (from htt
ps://pypi.python.org/simple/pip/), version: 0.7
Found link https://pypi.python.org/packages/source/p/pip/pip-0.8.1.tar.gz#md5=5d40614774781b118dd3f10c0d038cbc (from h
ttps://pypi.python.org/simple/pip/), version: 0.8.1
Found link https://pypi.python.org/packages/source/p/pip/pip-0.8.2.tar.gz#md5=df1eca0abe7643d92b5222240bed15f6 (from h
ttps://pypi.python.org/simple/pip/), version: 0.8.2
Found link https://pypi.python.org/packages/source/p/pip/pip-0.8.3.tar.gz#md5=0603337a81f83df2b1d2f1151565efac (from h
ttps://pypi.python.org/simple/pip/), version: 0.8.3
Found link https://pypi.python.org/packages/source/p/pip/pip-0.8.tar.gz#md5=468d9adc309f33ad51cee38f0d455429 (from htt
ps://pypi.python.org/simple/pip/), version: 0.8
Found link https://pypi.python.org/packages/source/p/pip/pip-1.0.1.tar.gz#md5=28dcc70225e5bf925532abc5b087a94b (from h
ttps://pypi.python.org/simple/pip/), version: 1.0.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.0.2.tar.gz#md5=47ec6ff3f6d962696fe08d4c8264ad49 (from h
ttps://pypi.python.org/simple/pip/), version: 1.0.2
Found link https://pypi.python.org/packages/source/p/pip/pip-1.0.tar.gz#md5=327fc4a03df189506966e15021730550 (from htt
ps://pypi.python.org/simple/pip/), version: 1.0
Found link https://pypi.python.org/packages/source/p/pip/pip-1.1.tar.gz#md5=62a9f08dd5dc69d76734568a6c040508 (from htt
ps://pypi.python.org/simple/pip/), version: 1.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.2.1.tar.gz#md5=db8a6d8a4564d3dc7f337ebed67b1a85 (from h
ttps://pypi.python.org/simple/pip/), version: 1.2.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.2.tar.gz#md5=99e44d1d7f88b182459e7c19c45aee9f (from htt
ps://pypi.python.org/simple/pip/), version: 1.2
Found link https://pypi.python.org/packages/source/p/pip/pip-1.3.1.tar.gz#md5=cbb27a191cebc58997c4da8513863153 (from h
ttps://pypi.python.org/simple/pip/), version: 1.3.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.3.tar.gz#md5=918559b784e2aca9559d498050bb86e7 (from htt
ps://pypi.python.org/simple/pip/), version: 1.3
Found link https://pypi.python.org/packages/source/p/pip/pip-1.4.1.tar.gz#md5=6afbb46aeb48abac658d4df742bff714 (from h
ttps://pypi.python.org/simple/pip/), version: 1.4.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.4.tar.gz#md5=ca790be30004937987767eac42cfa44a (from htt
ps://pypi.python.org/simple/pip/), version: 1.4
Found link https://pypi.python.org/packages/source/p/pip/pip-1.5.1.tar.gz#md5=4678c2ae5cce4e9234c3923d7dcb32f0 (from h
ttps://pypi.python.org/simple/pip/), version: 1.5.1
Found link https://pypi.python.org/packages/source/p/pip/pip-1.5.2.tar.gz#md5=5da30919f732d68b1c666e484e7676f5 (from h
ttps://pypi.python.org/simple/pip/), version: 1.5.2
Found link https://pypi.python.org/packages/source/p/pip/pip-1.5.3.tar.gz#md5=78871c5f84ea5fca61900347ce7864ad (from h
ttps://pypi.python.org/simple/pip/), version: 1.5.3
Found link https://pypi.python.org/packages/source/p/pip/pip-1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb (from h
ttps://pypi.python.org/simple/pip/), version: 1.5.4
Found link https://pypi.python.org/packages/source/p/pip/pip-1.5.tar.gz#md5=6969b8a8adc4c7f7c5eb1707118f0686 (from htt
ps://pypi.python.org/simple/pip/), version: 1.5
Skipping https://github.com/pypa/pip/tarball/develop#egg=pip-dev (from https://pypi.python.org/simple/pip/) because it
is externally hosted.
Installed version (1.5.4) is most up-to-date (past versions: 1.5.4, 1.5.4, 1.5.3, 1.5.3, 1.5.2, 1.5.2, 1.5.1, 1.5.1, 1.5
, 1.4.1, 1.4, 1.3.1, 1.3, 1.2.1, 1.2, 1.1, 1.0.2, 1.0.1, 1.0, 0.8.3, 0.8.2, 0.8.1, 0.8, 0.7.2, 0.7.1, 0.7, 0.6.3, 0.6.2,
0.6.1, 0.6, 0.5.1, 0.5, 0.4, 0.3.1, 0.3, 0.2.1, 0.2)
Requirement already up-to-date: pip in c:\python27\lib\site-packages
Downloading/unpacking install
Getting page https://pypi.python.org/simple/install/
Could not fetch URL https://pypi.python.org/simple/install/: 404 Client Error: Not Found
Will skip URL https://pypi.python.org/simple/install/ when looking for download links for install
Getting page https://pypi.python.org/simple/
URLs to search for versions for install:
* https://pypi.python.org/simple/install/
Getting page https://pypi.python.org/simple/install/
Could not fetch URL https://pypi.python.org/simple/install/: 404 Client Error: Not Found
Will skip URL https://pypi.python.org/simple/install/ when looking for download links for install
Could not find any downloads that satisfy the requirement install
Some externally hosted files were ignored (use --allow-external install to allow).
Cleaning up...
Removing temporary dir c:\users\mat\appdata\local\temp\pip_build_Mat...
No distributions at all found for install


Any ideas why this would be happening? The tutorial I'm following states I should use Python 2, would there be a reason not to use the Python 3? As i did hear pip comes packaged with Python 3...

Answer

I think the issue was resolved by uninstalling Python and reinstalling. I had previous had two versions installed and it might be possible that there was a conflict. Not over sure though. I will update this answer if I find out for sure.

Comments