AST AST - 3 years ago 377
Javascript Question

WebStorm “Let definition are not supported by current JavaScript version”

I am trying to use new tools available for coding in JavaScript. I've seen the post PhpStorm "Let definition are not supported by current JavaScript version". I've tried as suggested over there, but do not work.

When I hover over the

export



Export declarations are not supported by current JavaScript version


When I hover over the
yield



Generators are not supported by current JavaScript version


and hovering over the
let



Let definition are not supported by current JavaScript version


So the question is how to upgrade the JavaScript version?

Answer Source

It can be set up like in the following image:

enter image description here

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download