Storm Kiernan Storm Kiernan - 6 months ago 21
Ruby Question

Using RubyMine receiving errors

I am trying to learn Ruby on Rails. I purchased Ruby Mine and installed it on Ubuntu. I followed the installation instructions and when I tried to debug my first project in RubyMine, I get this:


Error running Development: test001: Failed to install gems.


Following gems were not installed: linecache19 (0.5.12): Error
installing linecache19: ERROR: Failed to build gem native extension.
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb *
extconf.rb failed *
Could not create Makefile due to some reason,
probably lack of necessary libraries and/or headers. Check the
mkmf.log file for more details. You may need configuration options.
Provided configuration options: --with-opt-dir --without-opt-dir
--with-opt-include --without-opt-include=${opt-dir}/include
--with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog
--without-make-prog --srcdir=. --curdir
--ruby=/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': no such file to load -- openssl (LoadError) from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/net/https.rb:92:in
' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/ruby_core_source-0.1.5/lib/contrib/uri_ext.rb:11:in
' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb:6:in
' from rubygems/custom_require>:33:in
require' from
rubygems/custom_require>:33:in
rescue in require' from
rubygems/custom_require>:29:in
require' from extconf.rb:2:in
' Gem
files will remain installed in
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/linecache19-0.5.12
for inspection. Results logged to
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/linecache19-0.5.12/ext/trace_nums/gem_make.out
/home/stormkiernan/Downloads/RubyMine-3.2.4/rb/gems/ruby-debug-base19x-0.11.30.pre2.gem:
Error installing ruby-debug-base19x-0.11.30.pre2.gem: ERROR: Failed to
build gem native extension.
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb ***
extconf.rb failed *** Could not create Makefile due to some reason,
probably lack of necessary libraries and/or headers. Check the
mkmf.log file for more details. You may need configuration options.
Provided configuration options: --with-opt-dir --without-opt-dir
--with-opt-include --without-opt-include=${opt-dir}/include
--with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog
--without-make-prog --srcdir=. --curdir
--ruby=/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': no such file to load -- openssl (LoadError) from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/1.9.1/net/https.rb:92:in
' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/ruby_core_source-0.1.5/lib/contrib/uri_ext.rb:11:in
' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb:6:in
' from rubygems/custom_require>:33:in
require' from
rubygems/custom_require>:33:in
rescue in require' from
rubygems/custom_require>:29:in
require' from extconf.rb:2:in
' Gem
files will remain installed in
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/linecache19-0.5.12
for inspection. Results logged to
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global/gems/linecache19-0.5.12/ext/trace_nums/gem_make.out


Now, just prior to this error, I was prompted with:


The gem ruby-debug-base19x required by the debugger is not currently
installed. Would you like to install it?


I responded "Yes", and it attempted (and I assume failed) to download whatever necessary dependencies the software needed. The window title was "Installing Gems". It was immediately after this window closed that I received the above error.

What do I need to do?

edit: Ruby Env

RubyGems Environment:
- RUBYGEMS VERSION: 1.8.10
- RUBY VERSION: 1.9.2 (2011-07-09 patchlevel 290) [x86_64-linux]
- INSTALLATION DIRECTORY: /home/stormkiernan/.rvm/gems/ruby-1.9.2-p290
- RUBY EXECUTABLE: /home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
- EXECUTABLE DIRECTORY: /home/stormkiernan/.rvm/gems/ruby-1.9.2-p290/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-linux
- GEM PATHS:
- /home/stormkiernan/.rvm/gems/ruby-1.9.2-p290
- /home/stormkiernan/.rvm/gems/ruby-1.9.2-p290@global
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://rubygems.org/


edit #2 showing errors:


$ gem install ruby-debug-base19x Fetching: linecache19-0.5.12.gem
(100%) Building native extensions. This could take a while... ERROR:
Error installing ruby-debug-base19x: ERROR: Failed to build gem
native extension.

/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby


extconf.rb
* extconf.rb failed * Could not create Makefile due to some
reason, probably lack of necessary libraries and/or headers. Check
the mkmf.log file for more details. You may need configuration
options.

Provided configuration options: --with-opt-dir --without-opt-dir
--with-opt-include --without-opt-include=${opt-dir}/include
--with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog
--without-make-prog --srcdir=. --curdir
--ruby=/home/stormkiernan/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
:29:in
require': no such file
to load -- ruby_core_source (LoadError) from
<internal:lib/rubygems/custom_require>:29:in
require' from
extconf.rb:2:in `'

Gem files will remain installed in
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290/gems/linecache19-0.5.12
for inspection. Results logged to
/home/stormkiernan/.rvm/gems/ruby-1.9.2-p290/gems/linecache19-0.5.12/ext/trace_nums/gem_make.out

Answer

Do the following from a command prompt instead:

sudo gem install ruby-debug-base19x

of if you're using rvm (recommended):

gem install ruby-debug-base19x

EDITED: type this first: rvm --default use 1.9.2