Alex Alex - 13 days ago 7
Linux Question

How to use multiple versions of GCC

We have a new application that requires glibc 2.4 (from gcc 4.1). The machine we have runs on has gcc 3.4.6. We can not upgrade, and the application must be run on this machine.

We installed gcc 4.1, however, when it comes to compile time it is using all the includes, etc, from 3.4.6.

How do we get around this?

Any suggestions on using 4.1 for just this application?

Answer

Refer "How to install multiple versions of GCC" here in the GNU GCC FAQ.

There's also a white paper here.

Comments