Adarkas2302 Adarkas2302 - 24 days ago 9x
Ruby Question

Can install cocoapods 1.1.0.rc.2 correctly

I am trying to install the cocoapods beta version 1.1.0.rc.2 because one of the pods i use needs this version. I did the following:

localhost:d.b.g. Melder DBG_MacAB$ mkdir -p §HOME/Software/ruby
localhost:d.b.g. Melder DBG_MacAB$ export GEM_HOME=§HOME/Software/ruby
localhost:d.b.g. Melder DBG_MacAB$ gem install cocoapods --pre
Fetching: cocoapods-1.1.0.rc.2.gem (100%)
Successfully installed cocoapods-1.1.0.rc.2
Parsing documentation for cocoapods-1.1.0.rc.2
Installing ri documentation for cocoapods-1.1.0.rc.2
1 gem installed
localhost:d.b.g. Melder DBG_MacAB$ export

After the seemingly successful install i checked the version and got this.

localhost:d.b.g. Melder DBG_MacAB$ pod --version

This is what i get from pod env.

CocoaPods : 1.0.1
Ruby : ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]
RubyGems : 2.4.8
Host : Mac OS X 10.11.6 (15G1004)
Xcode : 8.0 (8A218a)
Git : git version 2.8.4 (Apple Git-73)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib
Repositories : master - @ bfe37dea873630a4c6be6e71567f7a405a7853e5

After suggested from a member of the cocoapods github site i tried.

localhost:d.b.g. Melder DBG_MacAB$ pod _1.1.0.rc.2_ --version

So something seems to be fishy. Can someone point me in the right direction? Maybe i have to delete cocoapods and reinstall it, is there a way to do that via the terminal?


Solved my issue, i had more than one version of cocoapods installed, three versions in fact. I used gem list --local | grep cocoapods in the terminal to see all of them. Then i proceeded to uninstall everything and after reinstalling i had the pod version i wanted.