özkan özkan - 4 months ago 73
Android Question

Manifest merger failed, use tools:overrideLibrary

Error:Execution failed for task ':app:processDebugManifest'.


Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 17 declared in library [com.android.support:leanback-v17:23.2.1] C:\SampleforliveTVInputFrameworkTIFonTV\app\build\intermediates\exploded-aar\com.android.support\leanback-v17\23.2.1\AndroidManifest.xml
Suggestion: use tools:overrideLibrary="android.support.v17.leanback" to force usage


What should I do for this error

Answer

You are using a library ("com.android.support:leanback-v17:23.2.1") which has a minimum sdk version of 17 so you can not build your app for sdk version 17. If you don't need the library you should delete the line: compile 'com.android.support:leanback-v7:23.2.1' from your Module gradle file. If you need it you will nedd to change the minimum sdk version of your app to version 17. More information on this topic on: http://developer.android.com/reference/android/support/v17/leanback/package-summary.html