SubhasisM SubhasisM - 26 days ago 7
PHP Question

Error setting up Apache 2.4 server on windows 10

I am trying to setup apache2.4 on windows10 machine. I have downloaded the apache2.4 from apachelounge website, which I extracted and put in C drive. The lines I added in the httpd.conf file are-

LoadModule PHP5_module "c:/PHP/PHP5apache2_4.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/PHP"


Now when the run the below command in command prompt with "run as admin" privilege,

c:\apache24\bin\httpd -S


I am getting the below error -

httpd: Syntax error on line 522 of C:/Apache24/conf/httpd.conf: Can't locate API module structure `PHP5_module' in file C:/PHP/php5apache2_4.dll: No error


I have downloaded the PHP5.6 and extracted and put the same in C drive. Can anyone please me resolve this issue ?

Answer

Try to change LoadModule PHP5_module ... to LoadModule php5_module ..., some time ago I had this problem and changing this line from upper case to lower case helped me