Blaaaaa Blaaaaa - 1 year ago 389
Python Question

Python 3.5.1 Pygame Installation

I am trying to install Pygame for Python 3.5.1, but it tells me to upgrade to the new version of pip. "You are currently using 7.1.2, use 8.1.2".

Here is a screen shot of it: Python 3.5.1 pip

Another screenshot

Answer Source

The error clearly states Access Denied.
Try to run cmd/powershell as administrator.

The installation error is not because of pip , though you should still upgrade pip
python -m pip install --upgrade pip


Pygame does not have python3.5 support yet. Check the binaries here

Pygame binaries

Try to use Python version 3.4 or 2.7 and then install pygame.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download