Adi Z Adi Z - 4 months ago 160
Android Question

Access to the Dex is now impossible, starting with 1.4.0

when i want to sync gradle i get this error:

Error:Access to the dex task is now impossible, starting with 1.4.0
1.4.0 introduces a new Transform API allowing manipulation of the .class files.
See more information: http://tools.android.com/tech-docs/new-build-system/transform-api


When i click the link, i don't find any solution.
Anyone have solution thanks.

Answer

set your gradle version explicitly to 1.3.0 in dependencies section of build.gradle file

classpath 'com.android.tools.build:gradle:1.3.0'
Comments