Никита Лещёв Никита Лещёв - 5 days ago 5
Android Question

Can't build CSipSimple

I'm trying to build CSipSimple

I get such error:

# External sources fetched out from external repos/zip
/Users/Nikita.Leshchev/Library/Android/sdk/ndk-bundle/build/core/build-local.mk:151: *** Android NDK: Aborting . Stop.
/Users/Nikita.Leshchev/Library/Android/sdk/ndk-bundle/build/core/build-local.mk:151: *** Android NDK: Aborting . Stop.
Isources/modules/audio_processing/aecm/include -Isources/modules/audio_processing/aecm/../utility -Isources/modules/audio_processing/aecm/../../.. -Isources/modules/audio_processing/aecm/../../../common_audio/signal_processing/include -Isources/modules/audio_processing/aecm/../../../system_wrappers/interface -mfpu=neon -mfloat-abi=softfp -flax-vector-conversions -S -o sources/modules/audio_processing/aecm/aecm_core_neon_offsets.S sources/modules/audio_processing/aecm/aecm_core_neon_offsets.c
make[1]: Isources/modules/audio_processing/aecm/include: No such file or directory
make[1]: [sources/modules/audio_processing/aecm/aecm_core_neon_offsets.S] Error 1 (ignored)
Traceback (most recent call last):
File "sources/build/generate_asm_header.py", line 46, in <module>
main(sys.argv[1:])
File "sources/build/generate_asm_header.py", line 30, in main
infile = open(argv[0])
IOError: [Errno 2] No such file or directory: 'sources/modules/audio_processing/aecm/aecm_core_neon_offsets.S'
make[1]: *** [sources/modules/audio_processing/aecm/aecm_core_neon_offsets.h] Error 1
make: *** [webrtc-preprocess] Error 2


Here suggests to check variables and installed soft. But my variables is ok

echo $PATH
output:

/opt/local/bin:/opt/local/sbin:/usr/local/php5/bin:/Users/Nikita.Leshchev/Downloads/pcre-8.39/bin:/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk/System/Library/Frameworks/JavaVM.framework/Versions/A/Headers:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/Users/Nikita.Leshchev/Library/Android/sdk/tools:/Users/Nikita.Leshchev/Library/Android/sdk/platform-tools:/Users/Nikita.Leshchev/Library/Android/sdk/ndk-bundle/


Variables
ANDROID_NDK
and
ANDROID_SDK
defined. All required soft installed

which ndk-build
output:

/Users/Nikita.Leshchev/Library/Android/sdk/ndk-bundle//ndk-build


I did everything like in documentation, but i have this error. Can anybody help?

NDK Version 13.11.3345770

SDK Version 25.2.2

OSX 10.11.6

Answer

I solved my problem, not on 100% for a while, but this error i have resolved. This and some other files i found in this repository

Comments