Juliatzin del Toro Juliatzin del Toro - 3 months ago 94
PHP Question

Upgrade from Laravel 5.2 to Laravel 5.3

I want to update Laravel to the latest version 5.3.

I'm checking the official guide, but I don't see how to actually upgrade the code through composer.

When I try to update composer.json file to point to laravel/framework 5.3.*.

I get:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- laravelcollective/html v5.2.4 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- laravelcollective/html v5.2 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- laravelcollective/html v5.2.1 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- laravelcollective/html v5.2.2 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- laravelcollective/html v5.2.3 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- laravelcollective/html v5.2.4 requires illuminate/view 5.2.* -> satisfiable by laravel/framework[v5.2.44], illuminate/view[v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.6, v5.2.7].
- Can only install one of: laravel/framework[v5.3.0, v5.2.44].
- don't install illuminate/view v5.2.0|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.19|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.21|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.24|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.25|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.26|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.27|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.28|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.31|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.32|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.37|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.43|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.6|don't install laravel/framework v5.3.0
- don't install illuminate/view v5.2.7|don't install laravel/framework v5.3.0
- Installation request for laravel/framework 5.3.* -> satisfiable by laravel/framework[v5.3.0].
- Installation request for laravelcollective/html 5.2.* -> satisfiable by laravelcollective/html[v5.2, v5.2.1, v5.2.2, v5.2.3, v5.2.4].


How should I update ???

Tx

Answer

In your composer.json, replace:

"laravelcollective/html": "5.2.*"

with:

"laravelcollective/html": "5.3.*@dev"


After version 5.3 of this package is released, you will be able to switch to stable branch: "5.3.*"

Comments