I have XCode 7.3.1 installed on OSX Sierra. I do not want to update to XCode 8.
However, I need to install Cocoapods and I am receiving an error stating that Ruby 2.2.0 is a requirement. My machine has Ruby 2.0.0
So I set about updating Ruby but have run into difficulty doing this.
If I use RVM or Brew to install ruby 2.2.0 I get the following:
Error: Your Xcode (7.3.1) is outdated.
Please update to Xcode 8.0 (or delete it).
Error installing cocoapods:
activesupport requires Ruby version >= 2.2.2.
Because OSX comes with the default Ruby for its own use, you have to install Bundler form this command
$ gem install bundler after you have done this install run this command
$ bundle install ruby to install the latest Ruby Update.
This is not working, because it is selected so that I cant delete it.