Nick White Nick White - 8 days ago 5
JSON Question

Bower dependency versions

I am using bower currently as well as an Angular. One of the plugins I am using (ngTable) has a dependency ~1.2.9

Currently am getting confused one what this actually means.

If I set angular as =1.2.14 this still runs fine but in the output of the command line it mentions 1.2.9 angular as well as .14

Some clarity on this would be greatly appreciated.

My current understand (which may be wrong) is that

= (Means that it will always be that)
> (Means putting 1.2 will allow for the highest of 1.2 until 1.3)
=> (Means equal or more same as above)


But when it comes to >1.2.9 or ~1.2.9 I'm not sure

Answer

~1.2.9 means the last patch version starting from 1.2.9.

Update: So 1.2.9, 1.2.10, 1.2.11... but not 1.3

>1.2.9 means the version must be greater than 1.2.9. 1.3 is OK.

More information on the syntax for dependencies is available on npm site