tester tester - 2 months ago 227
Android Question

How to fix Error:Could not find com.google.gms: google-services: 3.0.0.?

I am trying to add firebase addmob in my app.

In build.gradle(Project) i have following code

buildscript {
repositories {
jcenter()
}
dependencies {
classpath 'com.google.gms: google-services: 3.0.0'
classpath 'com.android.tools.build:gradle:2.1.3'

// NOTE: Do not place your application dependencies here; they belong
// in the individual module build.gradle files
}
}


In build.gradle(module)

apply plugin: 'com.android.application'

android {
compileSdkVersion 23
buildToolsVersion "24.0.2"

defaultConfig {
applicationId "com.myname.examp.myapp"
minSdkVersion 14
targetSdkVersion 23
versionCode 1
versionName "1.0"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12'
compile 'com.android.support:appcompat-v7:23.0.0'
compile 'com.android.support:design:23.0.0'
compile 'com.google.firebase: firebase-ads: 9.0.0'
}
apply plugin: 'com.google.gms.google-services'


I have updated version of google play service and repository
enter image description here

When i sync project still i am getting following error

Error:Could not find com.google.gms: google-services: 3.0.0.
Searched in the following locations:
file:/C:/Program Files/Android/Android Studio2/gradle/m2repository/com/google/gms/ google-services/ 3.0.0/ google-services- 3.0.0.pom
file:/C:/Program Files/Android/Android Studio2/gradle/m2repository/com/google/gms/ google-services/ 3.0.0/ google-services- 3.0.0.jar
https://jcenter.bintray.com/com/google/gms/ google-services/ 3.0.0/ google-services- 3.0.0.pom
https://jcenter.bintray.com/com/google/gms/ google-services/ 3.0.0/ google-services- 3.0.0.jar
Required by:
:MyApplication:unspecified


Can some one help me how to fix this error

Answer

Please add google-services.json in your app folder.