sparkandshine sparkandshine - 14 days ago 9
Python Question

Upgrade the Python package dateutil: Could not find a version

I tried to upgrade

dateutil
from
2.5.3
to the newest version
2.6.0
with
pip install dateutil --upgrade
, but got the issue
Could not find a version
.

$ pip install dateutil --upgrade
Collecting dateutil
Could not find a version that satisfies the requirement dateutil (from versions: )
No matching distribution found for dateutil


I checked the post Could not find a version that satisfies the requirement . Running
pip freeze | grep dateutil
got,

$ pip freeze | grep dateutil
python-dateutil==2.5.3


How do I know which version satisfies my machine? Is it possible to upgrade
dateutil
to the newest version?

Answer

It is

pip install python-dateutil --upgrade