Arvind Kumar Anugula Arvind Kumar Anugula - 1 month ago 11
PHP Question

Need Symfony 2 MongoDB bundle which uses MongoDB.so extention

I am facing issue in production which has mongodb.so extention where our Symfony 2 ODM bundle is using mongo.so.

And also as mentioned in following reference link mongo.so is deprecated hence we don't want to use mongo.so further.

http://php.net/manual/en/mongo.installation.php

Right now we are using following bundles, these are using mongo.so and not supporting mongodb.so.

"doctrine/mongodb-odm": "~1.0",
"doctrine/mongodb-odm-bundle": "~3.0"


Please suggest me right Doctirine ODM bundle which uses MongoDB.so extention.

Answer

ODM itself will not support new driver until 2.0 is released, at the moment you can use mongo-php-adapter which implements ext-mongo's API atop ext-mongodb and mongo-php-library. For more informations you may want to see ODM's last release blogpost.