Jack Daniels Jack Daniels - 4 months ago 17x
Ruby Question

Error when executing rails s

I'm reading a book Cucumber and cheese by J.Morgan and I'm having a problem with the rails puppy app. Namely, when I execute rails s I get the following error -

/usr/local/lib/ruby/gems/2.2.0/gems/activesupport-3.2.1/lib/active_support/values/time_zone.rb:268: warning: circular argument reference - now
/usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:80:in `rescue in block (2 levels) in require': There was an error while trying to load the gem 'coffee-rails'. (Bundler::GemRequireError)
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:72:in `each'
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:72:in `block in require'
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:in `each'
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:in `require'
from /usr/local/lib/ruby/gems/2.2.0/gems/bundler-1.11.2/lib/bundler.rb:99:in `require'
from /home/iza/puppies/config/application.rb:7:in `<top (required)>'
from /usr/local/lib/ruby/gems/2.2.0/gems/railties-3.2.1/lib/rails/commands.rb:53:in `require'
from /usr/local/lib/ruby/gems/2.2.0/gems/railties-3.2.1/lib/rails/commands.rb:53:in `block in <top (required)>'
from /usr/local/lib/ruby/gems/2.2.0/gems/railties-3.2.1/lib/rails/commands.rb:50:in `tap'
from /usr/local/lib/ruby/gems/2.2.0/gems/railties-3.2.1/lib/rails/commands.rb:50:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'

P.S. I didn't post this question on the book author's site cause it seems to have been inactive for quite a long time :(

My Gemfile

source 'http://rubygems.org'

gem 'rails', '3.2.1'

gem 'json_pure'
gem 'spruz'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3-ruby', :require => 'sqlite3'
gem 'will_paginate'
gem 'jquery-rails'

group :assets do
gem 'sass-rails', '~> 3.2.4'
gem 'coffee-rails', '~> 3.2.2'
gem 'uglifier', '>= 1.2.3'

group :development, :test do
gem 'rspec-rails'

group :test do
gem 'page-object'
gem 'rspec'
gem 'cucumber'

My rails (4.2.5, 3.2.1)


It looks like you have't installed NodeJs

sudo apt-get install nodejs

Should work !!!