Jonathan Miller Jonathan Miller - 2 months ago 11
Node.js Question

Error running gulp-sass after update to Node v4.0.0

I updated to Node v4.0.0 and after when I run gulp in my projects I get an error with regards to gulp-sass/node-sass, as follows:

bindings not found. Try reinstalling

I've tried trashing all the node modules in the project and reinstalling, and I get some errors:

npm WARN package.json package@0.0.0 No repository field.

npm WARN package.json package@0.0.0 No license field.

npm WARN deprecated CSSselect@0.4.1: the module is now available as 'css-select'

npm WARN deprecated CSSwhat@0.4.7: the module is now available as 'css-what'

npm WARN deprecated pangyp@2.3.2: use node-gyp@3+, it does all the things


node-sass@2.1.1 install /Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass

node scripts/install.js

Can not download file from

node-sass@2.1.1 postinstall /Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass

node scripts/build.js

gyp: /Users/Jonathan/.node-gyp/4.0.0/common.gypi not found (cwd: /Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass) while reading includes of binding.gyp while trying to load binding.gyp

gyp ERR! configure error

gyp ERR! stack Error:
failed with exit code: 1

gyp ERR! stack at ChildProcess.onCpExit (/Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass/node_modules/pangyp/lib/configure.js:346:16)

gyp ERR! stack at emitTwo (events.js:87:13)

gyp ERR! stack at ChildProcess.emit (events.js:172:7)

gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)

gyp ERR! System Darwin 14.5.0

gyp ERR! command "/usr/local/bin/node" "/Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass/node_modules/pangyp/bin/node-gyp" "rebuild"

gyp ERR! cwd /Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass

gyp ERR! node -v v4.0.0

gyp ERR! pangyp -v v2.3.2

gyp ERR! not ok

Build failed

All the other node modules seem to have installed fine. Its something with node-sass thats in gulp-sass that is causing issues.


Delete your node_modules folder, update gulp-sass to the latest in your package.json, which is 2.2.0, and run npm install again.