juppy juppy - 1 month ago 8
iOS Question

Can I update Alamofire to version 4 and still support iOS 8 in my app?

I have a conclution and since I am a beginner, I just want to get it confirmed by someone else.

In my iOS app (Swift 2.2, Xcode 7) that must support iOS 8, I use Alamofire for server communication. Now my conclusion is that I will not be able to migrate the app to Xcode 8 and Swift 2.3 or 3.0, since I then have to use Alamofire version 4 and that version doesn´t suport iOS 8. So my app has to keep Alamofire version 3 which means that it has to stay Swift 2.2 and Xcode 7. Did i understand this correctly?

Alamofire 4 requirements:
https://github.com/Alamofire/Alamofire/blob/master/Documentation/Alamofire%204.0%20Migration%20Guide.md

Alamofire 3 requirements:
https://github.com/Alamofire/Alamofire/blob/master/Documentation/Alamofire%203.0%20Migration%20Guide.md

Answer

No you can't Alamofire 4.0 requirements:

  • iOS and tvOS 9.0+, macOS 10.11.0+, watchOS 2.0+
  • Xcode 8.0+
  • Swift 3.0+

If you would like to use Alamofire on iOS 8 or macOS 10.9, use the latest tagged 3.x release which supports both Swift 2.2 and 2.3.

Reference

Comments