berliner berliner - 4 months ago 21
Node.js Question

npm peerDependency - can't install package

I'm new to npm world, so maybe it's easy. The problem is the following:

I have a project with installed react

v.15.2.0
, and I need to install a package, e.g.
react typist
- https://github.com/jstejada/react-typist.
When I do it, I gen an error: (npm v2.*)


npm ERR! peerinvalid The package react@15.2.1 does not satisfy its
siblings' peerDependencies requirements!


Reading on the internet, I followed an advice to update npm itself to v.3, so I did it by running
npm install -g npm
. But the error is still there:


+-- UNMET PEER DEPENDENCY react@15.2.1


I assume, that I need to update react to
v.15.2.1
, but don't know how to do it. Running
npm update
doesn't help, still same error. Could you please advice, how to solve the issue?

enter image description here

enter image description here

enter image description here

Thanks.

Answer

The version message is the other way around to what you're thinking. It's saying "the version of react that you have is 15.2.1 and that doesn't match what react-typist needs".

Indeed if you look in the react typist package.json you'll see that they require version 0.14 of React. That's the problem. Looks like the repo hasn't been touched for almost a year, so you might want to pick something else, or fork it and make some changes.