jeff_h jeff_h - 3 months ago 66
Linux Question

Installing snort on Amazon Linux Dependancy Issue (libpcre.so.1)

I am trying to install snort on an amazon virtual machine, and I am running into a dependency issue. I would really appreciate any help! :D

Operating system info below:

# uname -a

Linux hostname 4.1.13-19.30.amzn1.x86_64 #1 SMP Fri Dec 11 03:42:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


I have downloaded the snort rpm, (the centos version as that is what amazon linux is based on, I have also tried directly with yum, and I have encountered the same issue). Evidence below:

# yum localinstall snort-2.9.8.0-1.centos7.x86_64.rpm
Loaded plugins: priorities, update-motd, upgrade-helper
Examining snort-2.9.8.0-1.centos7.x86_64.rpm: 1:snort-2.9.8.0-1.x86_64
Marking snort-2.9.8.0-1.centos7.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package snort.x86_64 1:2.9.8.0-1 will be installed
--> Processing Dependency: libdnet.so.1()(64bit) for package: 1:snort-2.9.8.0-1.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: 1:snort-2.9.8.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:snort-2.9.8.0-1.x86_64 (/snort-2.9.8.0-1.centos7.x86_64)
Requires: libdnet.so.1()(64bit)
Error: Package: 1:snort-2.9.8.0-1.x86_64 (/snort-2.9.8.0-1.centos7.x86_64)
Requires: libpcre.so.1()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


I check the depencdancy with yum, evidence below:

# yum provides libdnet
Loaded plugins: priorities, update-motd, upgrade-helper
libdnet-1.11-1.1.el3.rf.x86_64 : Simple portable interface to lowlevel networking routines
Repo : installed


Could the issue be related to a symbolic link?

Or could it be an operating system incompatibility issue?

Any help at all would be greatly appreciated! :D

Thanks!

Answer

This finally fixed the libdnet error for me:

sudo yum install libdnet-devel.x86_64 --enablerepo=epel

I also had to install these through yum to get Snort and DAQ to configure and make properly:

  • bison.x86_64
  • flex.x86_64
  • libpcap.x86_64
  • pcre-devel.x86_64

Those four didn't require the EPEL (extended package) repo from yum.

Comments