mp3por mp3por - 1 month ago 37
AngularJS Question

angular-cli produces syntax error when ran

I am trying to use the angular-cli project however I get this error when I run

$ ng new scotchy-scotch
C:\Users\....\AppData\Roaming\nvm\v0.12.10\node_modules\angular-cli\bin\ng:7
const resolve = require('resolve');
^^^^^
SyntaxError: Use of const in strict mode.
at exports.runInThisContext (vm.js:73:16)
at Module._compile (module.js:443:25)
at Object.Module._extensions..js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Function.Module.runMain (module.js:501:10)
at startup (node.js:129:16)
at node.js:814:3

Answer

From the angular-cli github page:

Prerequisites:

Both the CLI and generated project have dependencies that require Node 4 or higher, together with NPM 3 or higher.

The const are part of ES6(ECMAscript 2015) which is not enabled by default in nodejs v0.12(which one you use). Related stackoverflow article