user902691 user902691 - 3 months ago 45
Scala Question

Dependency for cassandra phantom

I have following

bulid.sbt


scalaVersion := "2.11.8"

libraryDependencies += "com.websudos" %% "diesel-engine" % "0.3.0"

libraryDependencies += "com.websudos" %% "phantom-dsl" % "1.27.0"


When
sbt
try resolve dependency following communicate is showing:

[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: UNRESOLVED DEPENDENCIES ::
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: com.websudos#diesel-engine_2.11;0.3.0: not found
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn]
[warn] Note: Unresolved dependencies path:
[warn] com.websudos:diesel-engine_2.11:0.3.0 (/path/build.sbt#L13-14)
[warn] +- com.websudos:phantom-dsl_2.11:1.27.0 (/path/build.sbt#L15-16)
[warn] +- default:webscraper_2.11:1.0
[trace] Stack trace suppressed: run last *:update for the full output.
[error] (*:update) sbt.ResolveException: unresolved dependency: com.websudos#diesel-engine_2.11;0.3.0: not found
[error] Total time: 2 s, completed 2016-07-11 18:19:22

Answer

The latest version of phantom available on Maven Central is 1.27.0. The diesel-engine does not get published to Maven Central at all, instead it gets published to our OSS Bintray repository.

resolvers += Resolver.bintrayRepo("websudos", "oss-releases") is the one you need to get diesel-engine to resolve properly. This is all described on the wiki page on integrating phantom, available here.