Sagar R. Kothari Sagar R. Kothari - 1 month ago 23
iOS Question

Fabric release XCode 6.3 codesign xcode-select

I'm trying to upload a release to Fabric & I'm getting errors as follows. I'm using the XCode 6.3 (recently updated).


  • XCode: 6.3

  • Fabric: 1.1.3

  • OSX: 10.10.3



An Error from Fabric tool


  1. What should I do to resolve above error & continue uploading the release via fabric desktop tool?

  2. Is there any other way to upload binary to fabric?


Answer

Mike from Fabric here.

1) To clear that error from Fabric.app: Quit Fabric.app, then run this command to clear the local cache: rm -rf ~/Library/Caches/com.crashlytics.mac (You may also need to clear rm -rf ~/Library/Caches/com.crashlytics, rm -rf ~/Library/Caches/com.crashlytics.data and rm -rf ~/Library/Caches/com.crashlytics.run) Then restart Fabric.app and you'll be all set!

2) To distribute outside of Fabric.app, use either method mentioned here.