Johnathan Johnathan - 8 days ago 6
Python Question

Python: how to get different versions of python to access the same modules?

I use a mac, and I have two versions of python (2.7 and 3.5). I installed scitools using

pip
and
import from scitools import *
works with 2.7 but not 3.5. I was wondering if it's because of links or something. I have included a screenshot. Thank you!

enter image description here

EDIT:

pip3 install scitools
gives:

enter image description here

wim wim
Answer

scitools requires Python 2.7 (source: github). It's apparently not actively maintained, so don't wait around for Python 3 support.