Ookey Ookey - 3 months ago 16
Swift Question

Alamofire and GoogleMaps pods

How to use

use_frameworks!
for only one pod? Because when i past
use_frameworks!
into podfile, GoogleMaps don't work.
My podfile:

target ‘somename’ do

#source 'https://github.com/CocoaPods/Specs.git'
platform :ios, ‘9.3’

pod 'GoogleMaps'
pod 'Alamofire', '~> 3.4'

end

Answer

Im' afraid you can't do it, according to this feature request and in fact is very reasonable, for example:

Transitive dependencies:

If Pod A is build dynamically and depends on Pod B that is build statically and the app also depends on Pod B, it is for example impossible to build, because either Pod A will be missing the symbols of Pod B at link time, or you end up with multiple copies of Pod B.

And it's very sad that a library like Google Maps not has support yet for the directive use_frameworks that it's necessary to build pod in Swift. You can another libraries like Fabric from Twitter.

I hope this help you.

Comments