georgephillips georgephillips - 1 month ago 14
Ruby Question

Can't require ruby gsl on Alpine Linux

I am running alpine in a docker image and running ruby code. This successfully installs all packages but fails when I try require gsl.

Here is the Dockerfile:

FROM alpine:3.4

RUN apk upgrade --update \
&& apk add libatomic readline readline-dev libxml2 libxml2-dev \
libxslt libxslt-dev zlib-dev zlib ruby yaml \
yaml-dev libffi-dev build-base git nodejs \
ruby-io-console ruby-irb ruby-json ruby-rake \
make gsl gsl-dev \
gcc g++ libffi-dev ruby-dev tzdata

RUN gsl-config --cflags
RUN gem install --no-document nmatrix gsl
ADD scripts/gsl-test.rb test.rb
RUN ruby test.rb


The test file is:

require 'gsl'


Running docker build . produces the following output:

Sending build context to Docker daemon 20 MB
Step 0 : FROM alpine:3.4
---> ad84c222f6a3
Step 1 : RUN apk upgrade --update && apk add libatomic readline readline-dev libxml2 libxml2-dev libxslt libxslt-dev zlib-dev zlib ruby yaml yaml-dev libffi-dev build-base git nodejs ruby-io-console ruby-irb ruby-json ruby-rake make gsl gsl-dev gcc g++ libffi-dev ruby-dev tzdata
---> Using cache
---> b7f66d6f2bd7
Step 2 : RUN gsl-config --cflags
---> Using cache
---> b5acc8868a74
Step 3 : RUN gem install --no-document nmatrix gsl
---> Using cache
---> 2623683a706e
Step 4 : ADD scripts/gsl-test.rb test.rb
---> e4388f952198
Removing intermediate container 743340a3be60
Step 5 : RUN ruby test.rb
---> Running in c53a34ece153
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': Error relocating /usr/lib/ruby/gems/2.3.0/gems/gsl-2.1.0.1/lib/gsl_native.so: gsl_multifit_fdfsolver_jac: symbol not found - /usr/lib/ruby/gems/2.3.0/gems/gsl-2.1.0.1/lib/gsl_native.so (LoadError)
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.3.0/gems/backports-3.6.8/lib/backports/std_lib.rb:9:in `require_with_backports'
from /usr/lib/ruby/gems/2.3.0/gems/gsl-2.1.0.1/lib/gsl.rb:11:in `<top (required)>'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:in `require'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:in `rescue in require'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:40:in `require'
from test.rb:1:in `<main>'
The command '/bin/sh -c ruby test.rb' returned a non-zero code: 1


Any assistance would be greatly appreciated.

Answer

I believe the problem is you're running gsl version 1.16 and then running the latest gsl gem (2.1.0.1). If you force the gem install to match the gsl version:

gem install --no-document gsl -v 1.16.0.6

It should work splendidly.