agentbanks217 agentbanks217 - 3 months ago 13
Ruby Question

RVM: How to use gems from a different ruby?

I have been using RVM to manage my Rubies and gems.

When I first installed RVM, the Ruby version that I installed was

1.9.2-p0
. I recently installed Ruby
1.9.2-p136
, which created a new Ruby in the RVM.

My problem is I want to use the latest version of Ruby but all of the gems I installed were installed under the
1.9.2-p0
directory, because RVM keeps gems completely separate between Rubies, and I want to be able to use those gems with my new version,
p-136
without having to reinstall them all.

Is there a way I can get my gems from my
p-0
Ruby to work with my
p-136
Ruby?

Answer

You need to check out gemsets and export your current gems.

rvm gemset export

Read the gemset docs for more information.

Comments